SC3900 hybrid mode issues


#1

g2wayne Mon Oct 05, 2015 4:52 pm

SC3900 hybrid mode issues Hi all! Let me try my best to make this as short as possible. I have a pair of SC3900’s and a dnx1600 mixer. I am currently running on an intel dual core 1.86GHz celeron with 4GB ram on WIN7 Pro SP1 64bit. I also tried a macbook pro with about basically the same specs. I have updated to the latest firmware provided on the website for all 3 pieces of equipment and followed the instructions provided to the letter! But whenever I try to use hybrid mode, the active spinning platter does not work! Everything else works except for the PLAY/PAUSE toggle and the platter. The cue button works fine and the pitch control works on some occasions. Can anyone tell me what my fault is??? I even made a video showing exactly what occurs when I try to operate the gizmo… I am using traktor 2. I have also tried vdj8. same issues! please help me someone! this is the vid i made: http://1drv.ms/1FgXe0U • SlayForMoney Mon Oct 05, 2015 6:12 pm Re: SC3900 hybrid mode issues I have watched your video, have a couple of questions and answers:

  1. For what do you need the X1600 midi map *.tsi file in the controller manager? If you don’t use X1600 midi buttons next to the FX section - please delete the midi map for now.

  2. Why is midi enabled on the X1600 channel 1 & 2? Disable.

  3. Input on the X1600 ch 1 & 2 is set wrong. It must be P1 and P2.

  4. You haven’t shown but mixer must be in CH mixing mode - not Master (default is CH)

  5. You haven’t shown one on the most important things: timecode settings on the players. Must be 2.5khz.

  6. When setting the mixer and players to MAC and timecode to 2.5khz, unplug them from the laptop. Only after you set them, plug the USB’s. And after you plug them, THEN start the Traktor.

  7. https://www.native-instruments.com/en/s … 600-mixer/

8… When you press play on the players, in Traktor - Preferences - Input routing you should see the input bars jumping meaning the mixer is receiving timecode from the players. If not, check that you have correctly plugged them via RCA into mixer inputs (line, not phono!) • g2wayne Mon Oct 05, 2015 7:42 pm Re: SC3900 hybrid mode issues Thanks for your assistance slay.

  1. I deleted the x1600 tsi mapping file as you suggested.
  2. I disabled midi on ch1 and 2 on the mixer
  3. The input values on line 1 and 2 are correct. They are currently P1 and P2
  4. The mixer is in CH mode. Blue LED selected…
  5. The frequency on both decks is 2.5KHz as you suggested. I double checked.
      1. I also checked these. The input bars do not jump when I press PLAY on the SC3900’s. The same thing happens. No response from the PLAY/PAUSE toggle or the active platter. Only everything else. Nothing has changed. The controllers work fine in USB or CD mode tho

EDIT:

Does it have anything to do with the timecode settings menu in traktor? Because my timecode menu doesn’t really say much. • SlayForMoney Tue Oct 06, 2015 9:18 pm Re: SC3900 hybrid mode issues Don’t worry, we’re getting closer to the problem.
Post your timecode settings window in Traktor.

So Traktor is not recieving the timecode. You do have SC3900 connected with RCA cable on the LINE inputs of the X1600, right? When you switch matrix input on the X1600 from P1 to Line, do you hear the timecode signal?

If yes, lets move on. Try using Traktor Wizard and select the X1600 as your mixer. • g2wayne Wed Oct 07, 2015 12:44 am Re: SC3900 hybrid mode issues Hi again… Yes I do hear the timecode signal when I switch the input. Its an annoying high pitched beeeeeeeeeeeeeeeeping sound. There is also a response when I scratch the platter. I ran the wizard again as you suggested. Everything is perfectly fine except the original issue. The mixer works fine. The controllers work as well but not the PLAy/PAUSE and the active platter… This is hard!

See my screenshots http://1drv.ms/1Z99F5P

SlayForMoney Wed Oct 07, 2015 4:59 pm Re: SC3900 hybrid mode issues g2wayne wrote:There is also a response when I scratch the platter.

I guess you mean by that: when you scratch the platter, you hear a change in the timecode signal? Not a responce in Traktor.

Ok, let me first clarify this. When the players are in the hybrid mode, they send midi messages via USB for everything except: play/pause, pitch fader and platter. They control the timecode signal that is being transmited through the RCA’s to the mixer. Now we know that players work just fine and they are not the problem.

Problem can be ASIO drivers (win only) and Traktor. In your first printscreen we can see that on Traktor decks under the timecode circle you have “Scratch Disabled”. That indicates that problem is with Traktor. What is the version of Traktor? Is it legally purchased (I have seen such problems with cracked copies of Traktor)? There are currently no 64-bit ASIO drivers for X160064-bit Traktor, you must have 32-bit Traktor installed (I believe that, if it were the case, Denon ASIO wouldn’t even be listed as a option under “Audio Setup” so I’m mentioning it just in case ). Mac doesn’t use ASIO drivers so that’s not a issue on mac.

Also, when you launch Denon ASIO setup, is everything enabled? On the first glance, everything seems ok regarding settings in Traktor. I would like other members here to join (many of you are using X1600 with timecode) to help with this one, I don’t have the same gear and it been a while since I helped a friend with his X1600

DJ Semi Type of DJ: Bar / Club DJ Thu Oct 08, 2015 12:51 pm Re: SC3900 hybrid mode issues SlayForMoney wrote:Problem can be ASIO drivers (win only) and Traktor. In your first printscreen we can see that on Traktor decks under the timecode circle you have “Scratch Disabled”. That indicates that problem is with Traktor.

Slay is on the Money.

The “Scratch Disabled” message means that the Hybrid Timecode signal from your 3900’s isn’t reaching the Traktor decks. This means one of a few things:

  1. Your Hybrid signal is the wrong frequency (i.e. not 2.5khz)
  2. You haven’t put the RCA cables into the right channel lines
  3. You haven’t set the Matrix inputs to the correct values (should be the appropriate 'P1, P2, P3 or P4 setting).

With those 3 things all checked and your audio inputs and outputs correctly set in Traktor, pressing play should allow you to see an input signal and press ‘Calibrate’ on the scope section of each deck receiving Timecode. Can you follow the following guide to the LETTER and verify if you are still facing issues after doing so?

g2wayne Thu Oct 08, 2015 1:46 pm Re: SC3900 hybrid mode issues When the players are in the hybrid mode, they send midi messages via USB for everything except: play/pause, pitch fader and platter.

Basically what this means is that my response from the hardware /software interaction seems to be correct thus far. The timecode sent from the RCAs is what I have to work on now… This is finally becoming clearer. Regarding the traktor version, it is legit, &it is the x86 version.

  1. Your Hybrid signal is the wrong frequency (i.e. not 2.5khz)
  2. You haven’t put the RCA cables into the right channel lines
  3. You haven’t set the Matrix inputs to the correct values (should be the appropriate 'P1, P2, P3 or P4 setting).

I will verify these options when I setup later and get right back to you guys! Thanks for all the help. I hope that everything works out after all this money I spent! Lol

One final question though, do I need any additional hardware? Like a soundcard box or something? Because the only things I have are as follows: mixer, controllers, laptop &cables.

I smell victory around the corner!!!

• g2wayne Sat Oct 10, 2015 3:00 am Re: SC3900 hybrid mode issues Ooooh! Its version 2.68 So I’ll begin by saying that my error was a lack of scrupulousness with regard to the RCA cables. Thank you guys for helping me to figure out that this was essentially the key to activating the timecode handshake. After connecting the RCA cables in their respective positions properly, I finally saw Scratch control status ACTIVE in Traktor. But on my 64bit machine, everything froze. Nothing worked. I then switched to a machine processing on x86 and VOILA!!! Everything was perfect!!! Its finally working
When the players are in the hybrid mode, they send midi messages via USB for everything except: play/pause, pitch fader and platter. They control the timecode signal that is being transmited through the RCA’s to the mixer.

  1. You haven’t put the RCA cables into the right channel lines
  2. You haven’t set the Matrix inputs to the correct values (should be the appropriate 'P1, P2, P3 or P4 setting)

And the world stopped for a second!

It never occurred to me that when the X1600 is in USB B-mode with the matrix switches on P1 /P2 etc… The RCAs take on a new function of digital data transmission between the mixer and controller(s). I always saw RCAs as simply for analogue audio transmission. I don’t think there is anywhere explaining this in detail for the common noob
Maybe I should post a tutorial on youtube sometime… If no one beats me to it…

Thanks a trillion slay / semi!


#2

Hi guys. I am Tom, and I have same problem with sc3900, X1700, and traktor. I need help. I did try everything but no play, no scratch function. I have windows 10 64bit. How can I to changed the sample rate on decks or mixer? Because when I open the asio window, the decks on 44,1khz, the mixer is on 96khz. I need help.


#3

Do you have the ordinary Traktor program, or the Traktor Scratch version?


#4

Did you read the manuals for the mixer and players? They don’t need to be on the same sample rate frequency, only your mixer has to be set the same as the software. Set you mixer to 44.1kHz.

Follow this guide: https://support.native-instruments.com/hc/en-us/articles/209576189 If you don’t succed, please give us more info of exactly WHERE are you stuck. Also, make sure you have the 64-bit Denon ASIO driver installed.


#5

I have got a Traktor Scratch Pro 2 demo version cd.


#6

Yes, I always read when I try to set. I can’t to change the sample rate on the mixer. It’s always 96000.


#7

Unplug the USB cable before trying to set the sample rate.


#8

Ok. I will try. What about mixer source in hybrid mode? X1600 has the ch1-4, USB and P. X1700 has not P. X1700 has D. (digital) Which one the good? I installed the downloaded asio drivers from denon website, and from asio website ( asio4all). I started traktor in 32bit mode, but no play button and no scratch. What about USB audio out settings in the mixer? I can to change any USB channel (usb1/2, USB3/4, usb5/6, usb7/8) to ch1-4, master or mic.


#9

source select knobs should be set to USB1/2, USB 3/4,…


#10

Source ok. Sample rate ok. But no play button, no scratch function, and no speed controll. Everything else is good. Hot cue buttons, second layer midi, loop, cue or bpm sync. It’s defenetly softver problem. Windows or asio driver? I will install a win 7. 32 or 64bit?


#11

Problem solved. USB audio settings on mixer. DVS. But one more little problem. I got this message in traktor: "Calibration failed Check needles and record." But now working fine everything so its not a big problem. But if somebody know the solution…


#12

Disable the message in Traktor preferences. It’s normal.


#13

I have this problem too)