Problem on my jog wheel!


#1

Plz check the movie , This has been a strange situation for both players . I’m currently out of town to run the party suddenly shocked in the sound check novel

Movie : https://youtu.be/owBOu_NA21s


#2

Hey Mamsi

Check this forum post for another user with the same issue and the suggested solution


#3

What to do for tonight ?


#4

Try to find a grounded plug in that place. Grab an extension cord to use with a socket further away.

That venue looks like a fairly nice place. They should(hopefully) have correct grounding somewhere.


#5

I’ve been running partys for years with different hardware in this venue and I’ve never had this problem with them , is this a bug on this device? Is this device not recommended for those who are always on the tour on different venue ?


#6

Hi Mamsi,

did you try a grounded outlet like i suggested? We can’t know if this is a bug if you don’t try the suggestions given so far. The device has a capacitive jog wheel and is required to be grounded properly. This device is being used all over the world by touring dj’s that haven’t had this issue, so yes it is recommended for them


#7

Doing what you said did not fix the problem. I had to turn off the vinyl button until the end of the show


#8

Have you had this issue only at this venue? or has it happened at other places where you’ve used the equipment?


#9

I’m playing in different places, The place I was last night There normaly i working 3 times a month, now driving to the another new place, praying for the tonight party…


#10

I’ve sent you a direct message. Check your inbox here


#11

@Alan_inMusic - rather than start a new thread, thought I would throw a similar issue into this one. (Feel free to break off into its own thread if you feel that’s the better route.)

Over the past week I noticed a strange “skipping” and “static” sound occasionally coming out of the audio chain. I checked cables and all the usual steps. At a show this past weekend it got really bad and then I remembered a couple of things I’ve read here on the forums and did a little experimenting.

Anyway, the issue is definitely tied to the jog. When attempting to nudge (ie, only touching the side, not the top) the static and skipping would start. Looking closely at exactly what was happening on the screen the best way to describe it would be “micro-scratching” - a bunch of little stop start motions etc. while trying to nudge. Turning off Vinyl mode immediately fixed the problem.

So I had this problem at two venues. Both locations I play at weekly and haven’t had any issues in the past. And both locations I use a high quality, fully ground protected power bar (including trouble indications) so if there was indeed an issue with the grounding off the wall supply it should have been detected.

To date I’m only noticing it on one of my decks. Both decks are about a year old now.