"Hardware failed to connect. Please try Again."


#1

I currently bought the Denon DJ DS1 dvs interface. I am currently connecting it to a Audio Technica AT-LP120 and AA mixer. now that i am trying to use the dvs whenever i plug it into serrate i get this message first “DS1 hardware connecting. This can take up to one minute” about a minute later i get this message “Hardware failed to connect. Please try Again.”. I have tried looking at various forums but see no help for my particular problem. I have downloaded the latest versions of serato and the firmware of the cvs is up to date. Mac also runs on the most current OS X. I just looking for some insight and help.


#2

Are you using a USB hub, or plugging directly into a USB port?

Is the blue light on the unit on, off, or blinking?


#3

I am plugging it in directly into my USB port, and yes the blue light does come on and does not blink.


#4

Hey Scully, is the DS1 a recent purchase? If its your first time connecting to the DS1, try resetting the midi connection on your Mac, this usually does the trick. Follow the steps below to reset this;

  1. Can you please close Serato DJ, connect the DS1, open up a finder window, and proceed to: Applications > Utilities > Audio MIDI Setup. In this window, you should see your DS1 Please check that your Built-in Input and Built-in Output are set as the default sound device. (If not, please make them so.)

  2. Next, please open the list menu Window > Show MIDI Studio. (⌘2) Scroll across till you see your hardware listed. With the icon highlighted, turn off and unplug your DS1, then remove that device from the view. Can you connect your DS1 to your computer again, and try to run the software once more?

  3. If you’re still having issues, please go back to the MIDI Studio and in the configuration drop down box, please select, and change from ‘Default’ to ‘New Configuration.’

Hope this helps.


#5

#6

Thank you for your insight, this allowed the DS1 to connect.